Outboard Oil Alarm - Manitoba Fishing Forum - The Premier Fishing Forum Of Manitoba
Reply
 
LinkBack Thread Tools
Old 04-10-2017, 11:15 AM   #1 (permalink)
Pro Angler
 
Daddy Smo's Avatar
 
Join Date: Jan 2017
Posts: 89
Thanks: 63
Thanked 42 Times in 21 Posts
Default Outboard Oil Alarm

I have a 30 HP Merc 4 stroke. Last year the oil alarm kept going off when the engine was at full RPM. Steady alarm. Checked oil levels and water output temperature. All ok. Anyone have any suggestions or know a good/familiar place in Wpg to have this checked out? Thanks.
Daddy Smo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-10-2017, 01:57 PM   #2 (permalink)
The Expert
 
Join Date: Sep 2016
Posts: 264
Thanks: 3
Thanked 169 Times in 88 Posts
Default

If your able to, bring it to Neil at Lakeway at the corner of 44 and 59 Hwy. No bullcrap with him, will give you an honest opinion.
claimkevin is offline   Reply With Quote Quick reply to this message
The Following 4 Users Say Thank You to claimkevin For This Useful Post:
Daddy Smo (04-11-2017), Fish1 (04-10-2017), gotaf7 (04-10-2017), jason7mm (04-10-2017)
Old 04-10-2017, 03:02 PM   #3 (permalink)
The Grand Master
 
Join Date: Mar 2012
Posts: 529
Thanks: 589
Thanked 309 Times in 182 Posts
Default

^^^ this ^^^
jason7mm is offline   Reply With Quote Quick reply to this message
The Following User Says Thank You to jason7mm For This Useful Post:
Daddy Smo (04-11-2017)
Sponsored Links
Advertisement
 
Old 04-10-2017, 08:47 PM   #4 (permalink)
The Grand Master
 
gotaf7's Avatar
 
Join Date: Apr 2012
Posts: 627
Thanks: 276
Thanked 610 Times in 258 Posts
Default

Quote:
Originally Posted by jason7mm View Post
^^^ this ^^^
I agree!
gotaf7 is offline   Reply With Quote Quick reply to this message
The Following User Says Thank You to gotaf7 For This Useful Post:
Daddy Smo (04-11-2017)
Old 12-18-2017, 01:08 PM   #5 (permalink)
The Expert
 
Join Date: Jun 2016
Posts: 262
Thanks: 115
Thanked 169 Times in 76 Posts
Default alarm

I have had mine go off but it was because I was trimmed to high and the engine was over reving
SlyFox is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Manitoba Fishing Forum - The Premier Fishing Forum Of Manitoba forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 02:08 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.